Amazon Web Services (AWS)

Incident Report for AppState Status Page

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 09:14 EDT

Monitoring

ITS is closely monitoring an Amazon Web Services Outage in the US-EAST-1 region. These problems are impacting multiple services that depend on AWS infrastructure. For real time updates on this situation please refer to the AWS Health Dashboard: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 12:07 EDT
This incident affected: Other Services.