Confluence and IT Knowledge base are unavailable
Incident Report for AppState Status Page
Resolved
This incident has been resolved.
Posted Nov 08, 2023 - 08:56 EST
Investigating
ITS is investigating an issue with Confluence. Confluence and the IT Knowledge base system are currently unavailable.
Posted Nov 08, 2023 - 07:39 EST
This incident affected: Other Services.