App State Careers Site (PeopleAdmin)

Incident Report for AppState Status Page

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 12:49 EST

Investigating

App State Careers Site (PeopleAdmin) is currently experiencing intermittent access issues.
Posted Feb 27, 2026 - 10:57 EST
This incident affected: AppState Careers Site (PeopleAdmin).