Duo Universal Prompt
Incident Report for AppState Status Page
Resolved
Posted Sep 22, 2022 - 08:42 EDT
Monitoring
The new DUO Universal prompt is live. See our KB article for more information
Posted Sep 21, 2022 - 09:10 EDT
This incident affected: Authentication (Duo Authentication).