Regional Internet interruption

Incident Report for AppState Status Page

Resolved

This incident has been resolved.
Posted Aug 01, 2025 - 09:48 EDT

Monitoring

Multiple ISPs in the high country are experiencing connectivity interruption. ITS is monitoring
Posted Jul 31, 2025 - 10:44 EDT
This incident affected: Networking (General Networking).