Update from JAGGEAR support Mon, Oct 20, 2025 at 1:32 PM:
JAGGAER is actively monitoring the ongoing AWS service outage affecting the us-east-1 region. While our environments have been largely unaffected, we have recently observed a small number of application servers impacted by this AWS issue.
Thanks to our highly available architecture, user impact has been minimal and temporary. Some users may have experienced brief errors when accessing JAGGAER applications; however, refreshing the page or starting a new browser session has typically restored full access.
Our Cloud Operations team continues to closely monitor the situation and will take any necessary actions to maintain service stability. We will provide additional updates as information becomes available from AWS or if any change in impact occurs.
Thank you for your patience and understanding.
Posted Oct 20, 2025 - 13:47 EDT
Investigating
JAGGAER US PRODUCTION Environment began experiencing performance issues around 12:37 PM EST today, October 20, 2025. We are actively monitoring this issue and will post updates as they are released from JAGGAER.