PaperCut maintenance

Incident Report for AppState Status Page

Resolved

Maintenance is complete.
Posted Aug 29, 2026 - 14:32 EDT

Identified

The PaperCut printing service is undergoing an out-of band security patch. Printing services will be limited during this time.
Posted Aug 29, 2026 - 08:00 EDT
This incident affected: Campus Printing.