Emburse Enterprise (also referred to as Chrome River)

Incident Report for AppState Status Page

Resolved

This incident has been resolved.
Posted Sep 15, 2026 - 15:48 EDT

Investigating

Emburse Enterprise (also referred to as Chrome River) is currently unavailable for campus users. We will post additional information about this outage as it becomes available.
Posted Sep 15, 2026 - 13:05 EDT
This incident affected: Other Services.